Some Kindles will no longer connect to the Internet if they aren’t updated by Tuesday

I updated my Kindle Touch from 2012 last night. It needs to run version 5.3.7.3. Simply connect it to Wifi (via Menu and Settings), go to Menu again and select “Sync and Check for...